On macOS 10.15, device fail-safe recovery using Dante Updater failed, with the message “Dante Updater cannot be opened because the developer cannot be verified”. Why is this? | Audinate | FAQs
FAQs

On macOS 10.15, device fail-safe recovery using Dante Updater failed, with the message “Dante Updater cannot be opened because the developer cannot be verified”. Why is this?

It has come to Audinate’s attention that certain Dante devices (including Brooklyn II-based devices, Broadway-based devices, and PCIe cards) cannot be successfully recovered from fail-safe using Dante Updater on macOS 10.15.7, and possibly also macOS 10.15.6. 

A fix for this issue is currently under development and is targeted for release in early January 2021. 

In the meantime, Audinate strongly recommends that you avoid macOS 10.15.6 and 10.15.7 in production environments where fail-safe recovery may be required, or alternatively ensure there is availability of a backup computer running Windows, or an earlier version of macOS.